Hyundai Tucson Forum banner
21 - 33 of 33 Posts

·
Registered
Joined
·
5 Posts
So looking for some advice. I took the car back in for service. This would have been the 6th time to address the safety warnings, etc. However, received a call from the service dept that the airbags spontaneously deployed with the technician inside. That being said about two weeks ago I agreed to start a buyback. Does this mean the car is totaled? If the vehicle is totaled does this affect my buyback process?
 

·
Registered
Joined
·
3 Posts
So looking for some advice. I took the car back in for service. This would have been the 6th time to address the safety warnings, etc. However, received a call from the service dept that the airbags spontaneously deployed with the technician inside. That being said about two weeks ago I agreed to start a buyback. Does this mean the car is totaled? If the vehicle is totaled does this affect my buyback process?
Holy crap! I just got mine back from the dealer for the same Christmas tree dash after 6 weeks. They said it was the abs module, nope, then they opened a ticket with Hyundai Engineering.
They told them to replace the airbag module. That's seems to have fixed it, time will tell. But having your airbags randomly deploy tells me that may have been the issue.
 

·
Registered
Joined
·
5 Posts
Holy crap! I just got mine back from the dealer for the same Christmas tree dash after 6 weeks. They said it was the abs module, nope, then they opened a ticket with Hyundai Engineering.
They told them to replace the airbag module. That's seems to have fixed it, time will tell. But having your airbags randomly deploy tells me that may have been the issue.
So they replaced the abs module the first time I had it serviced it maybe ran for 300 miles before it reappeared. I hope you have better luck!!!
 

·
Registered
Joined
·
2 Posts
So my all my warning lights/safety features/brake come on and I can’t drive this happens randomly? Anyone else ever see this? It’s a 2022 Tuscon limited. Annoying gonna have to take to dealer. Its when I just get in to start car. It list all safety feature errors see attached pics View attachment 247 View attachment 248 View attachment 247 View attachment 248 View attachment 249 View attachment 250
This just happened to me this evening on my way home from work. I have had the car for 1 week. It has right at 400 miles on it. I’ve read through all of the replies and this sounds like there needs to be a recall or something. I’ll call the dealership tomorrow.
 

·
Registered
Joined
·
9 Posts
So looking for some advice. I took the car back in for service. This would have been the 6th time to address the safety warnings, etc. However, received a call from the service dept that the airbags spontaneously deployed with the technician inside. That being said about two weeks ago I agreed to start a buyback. Does this mean the car is totaled? If the vehicle is totaled does this affect my buyback process?
Them setting off the airbags should not affect your buyback value. I would suggest you get a lawyer if you're not already working with one and make a lemon law claim with Hyundai if you don't like the value they try to provide you in the buyback.
 

·
Registered
Joined
·
2 Posts
This just happened to me this evening on my way home from work. I have had the car for 1 week. It has right at 400 miles on it. I’ve read through all of the replies and this sounds like there needs to be a recall or something. I’ll call the dealership tomorrow.
I took my car in today. At this point, they think it’s fixed. They found a pin the the camline that was not fully engaged.
 

·
Registered
Joined
·
1 Posts
Had the same issue of all warning lights popping and not going away. 2022 Hyundai Tucson Limited @ 744 miles, car barely 1 month old. Anyone able to get it fixed or identify the cause?
 

Attachments

·
Registered
Joined
·
2 Posts
Same issue here. Sporadically happens and often “resets” if the car is turned off and back on again. But wouldn’t reset yesterday until driving for awhile (without lights, turn signals, ac!) and then it magically came back to life and was fine the rest of the day. Thought battery issue but has sat for two weeks at a time without driving and it starts right up. AWD SEL model with 2200 miles in AZ heat.
 

·
Registered
2022 Tucson Hybrid Limited USA Market, Amazon Grey/Black With full OEM compact Spare
Joined
·
86 Posts
I had that FCW come on with my 21 Kona.

It always stayed on and no safety systems were active, but car was still driveable.

Repair started with 1500USD radar sensor behind front bumper and goes up from there.

Sold it due the issue, I think Hyundai still hasn't perfected the system faults since its showing up again and they are head scratching.

At least warrenty will take of it, but a major inconvenience is priceless.
 

·
Registered
Joined
·
1 Posts
I’m having a similar issue with my limited. All the warning lights come on and the e break won’t disengage when I turn it on. Waited 3 hours for a tow, the car worked fine when it arrived so I drove it home. Same issue the next morning leaving for work. I had read about a trick turning the car off and on a few times which worked and I was able to get there ok. When I tried to drive home, the “trick” worked until I drove about 30 feet. As I was about to drive out the parking lot, a cascade of failures occurred. I put it in reverse to get back into a parking spot, then the eagle-eye camera malfunctioned and disappeared, then the parking sensors stopped working and then the car applied the e break as I crawled to a stop. I have had this car 2 weeks!!

The dealership is being very cooperative and they have the car now. When I arrived, the person that checked in the car mentioned he has seen this happen when a sensor gets hit (like by a shopping cart). There was no external damage found. The manager mentioned something similar happened in a different Hyundai after a front impact. They put the car up to inspect the front end and mine was completely fine. The car still needs to be looked at by a technician. I’ll give updates as we go.
Car Vehicle Automotive design Motor vehicle Personal luxury car
 

·
Registered
Joined
·
2 Posts
Follow up to my post a few weeks ago... Issue continued to be sporadic and then drove from AZ to CA without issue until 9 hours into my trip and then all the warning lights came on. It drove fine with lights and turn signals working but no speedometer/nanny systems working. Happened on and off b/w CA to WA so took it to the dealer where I bought it when I got home. They said they could get to it in a month but I naturally raised a fuss regarding my 2 month old brand new vehicle so they let me leave it with them so they could see what they could do. They called me a couple days later and said it was fixed. There were fault codes related to "can communication." They "found pin tension JF08 joint is not fully secured. Re-secured connector pin." Essentially is was a loose wire. I've been driving it quite a bit for the past several days without any problem at all so I think it's fixed for real. (Fingers crossed! Knock on wood!) I don't know if this might be the same defect for others but hopefully it gives some people a lead.
 

·
Registered
2022 Tucson SEL FWD Amazon Grey Convenience/Premium/Cargo Pkgs
Joined
·
349 Posts
Follow up to my post a few weeks ago... Issue continued to be sporadic and then drove from AZ to CA without issue until 9 hours into my trip and then all the warning lights came on. It drove fine with lights and turn signals working but no speedometer/nanny systems working. Happened on and off b/w CA to WA so took it to the dealer where I bought it when I got home. They said they could get to it in a month but I naturally raised a fuss regarding my 2 month old brand new vehicle so they let me leave it with them so they could see what they could do. They called me a couple days later and said it was fixed. There were fault codes related to "can communication." They "found pin tension JF08 joint is not fully secured. Re-secured connector pin." Essentially is was a loose wire. I've been driving it quite a bit for the past several days without any problem at all so I think it's fixed for real. (Fingers crossed! Knock on wood!) I don't know if this might be the same defect for others but hopefully it gives some people a lead.
Unless it was you, someone else, somewhere, posted that same fix. I.E. the harness connector. Certainly fits that it could be the problem.

"The JF08 Series are complete harness assemblies using a Flat Flexible Cable (FFC) compatible with high speed differential signals commonly used in consumer devices to interface with LCD/OLED displays, camera modules and various I/O daughter boards."
 
21 - 33 of 33 Posts
Top