Hyundai Tucson Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have 430 miles on my Hybrid SEL Convenience. Very frequently when I reverse it takes a few minutes for the rear camera to turn off and the regular screen (music and time) on the infotainment to return. It's a bit annoying but today it did something really strange.

When I switched back to drive, the screen lagged as usual but in addition, the music that was playing started glitching like playing one note over and over, AND I received a call and couldn't answer it because NONE of the buttons on the infotainment or left steering wheel buttons worked. Even when I pushed the off (volume) button, it didn't do anything. It was kind of scary since I just got on the freeway. About 3 minutes later it went back to normal.

Has anyone experienced this? Does your rear camera lag to return to the normal screen? Is this something to notify the dealer about?

Thank you!!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #2 ·
I have 430 miles on my Hybrid SEL Convenience. Very frequently when I reverse it takes a few minutes for the rear camera to turn off and the regular screen (music and time) on the infotainment to return. It's a bit annoying but today it did something really strange.

When I switched back to drive, the screen lagged as usual but in addition, the music that was playing started glitching like playing one note over and over, AND I received a call and couldn't answer it because NONE of the buttons on the infotainment or left steering wheel buttons worked. Even when I pushed the off (volume) button, it didn't do anything. It was kind of scary since I just got on the freeway. About 3 minutes later it went back to normal.

Has anyone experienced this? Does your rear camera lag to return to the normal screen? Is this something to notify the dealer about?

Thank you!!

Oh and I know I received a call because my watch notified me.
 

·
Registered
Limited PHEV, Quartz White with grey interior
Joined
·
304 Posts
First things to try would be making sure you have the latest software load and then doing a hard reset of the head unit. If those steps don't work then you probably have the enviable task of convincing your dealer that you have a bad head unit.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
First things to try would be making sure you have the latest software load and then doing a hard reset of the head unit. If those steps don't work then you probably have the enviable task of convincing your dealer that you have a bad head unit.
Thank you for the tip. How do I know I have the latest software and is the rest button in settings?
 

·
Registered
Limited PHEV, Quartz White with grey interior
Joined
·
304 Posts
Software update instructions are on your MyHyundai page. You can display your current version on one of the screens in the car. (Note - The newest update requires at least a 64 GB USB drive to move the update from your computer to the car.)

Reset button is the little hole on the face of the infotainment system that you push with a pen or paper clip. Instructions should be in your manual.
 

·
Registered
2022 Hyundai Tucson SEL ICE with Premium package
Joined
·
9 Posts
I too face this issue of lagging rear camera even after changed to Drive mode. The display shows the rear area for some time until the car moves forward about 10 ft and then it shows main display. But I observed that to change the display to show the main screen immediately you just need to push the rear view camera button at shifter. Every time pushing that button is annoying.
 

·
Registered
Joined
·
15 Posts
In my settings (SEL+convenience pkg) I have the option for rear camera delay. Personally I love it, but I also know it's intentional. You should be able to turn it off under settings and display and then back up camera.
 
1 - 10 of 10 Posts
Top